DirectFB - Home of the pragmatist Roadmap


[directfb-users] Re: I can not show png pictures and ttf fonts
Mailing List archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[directfb-users] Re: I can not show png pictures and ttf fonts



Hi Edward,

there is obviously a bug in the cle266 DirectFB driver, which does only work if cle266vgaio is loaded. I think 'image' and 'text' work for me even with acceleration, but I cannot tell for sure until tomorrow since I do not have access to a cle266 today.

Do the examples from DirectFB-examples work? Please try df_andi.

andi


Thank you very much!

I've checked out your code from cvs. If I don't insert the cle266vgaio.o
module, then the tutorial programs 'image' and 'text' do work with the
new viafb but after I inserted the cle266vgaio module, these two program
cannot run properly anymore.

Do you have any clue about this?

/edward

Andreas Hundt wrote:

text and image work for me.

Do you use viafb or vesafb?

viafb has broken panning, so double buffering in DirectFB does not work.
I patched viafb and put in in our cvs.

Please check out:

linux-fb/cle266fb

andi


On Mon, 2003-11-24 at 16:12, Yidan(Edward) Zhou wrote:


I have installed DirectFB library and driver, and the FreeType and PNG
libraries as well. However, when i run 'text' and 'image' in the
tutorial package, these two programs can not show the png picture and
the decker font. the picture and the characters are replaced by blanks
with random dots on it. later on, i tried the font testing program
'df_fonts' and the result is same (characters are small blank pictures
with random dots on tem). the debug message of df_fonts are listed below







--
Info: To unsubscribe send a mail to ecartis@directfb.org with
"unsubscribe directfb-users" as subject.



--
Info: To unsubscribe send a mail to ecartis@directfb.org with "unsubscribe directfb-users" as subject.



Home | Main Index | Thread Index


directfb.org / Development / Old Archives