DirectFB - Home of the pragmatist Roadmap


[directfb-users] Re: I can not show png pictures and ttf fonts
Mailing List archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[directfb-users] Re: I can not show png pictures and ttf fonts



my hardware info

-- CPU info --
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 9
model name : VIA Nehemiah
stepping : 1
cpu MHz : 999.550

-- Extended VGA registers --
01 78 30 08 01 ae 08 1f
4e 00 1a f0 cc 00 f1 00
00 00 1f 00 00 00 0c 00
00 00 00 00 00 ff ff dc
d8 3d 40 00 3f 06 11 22
31 01 00 00 00 00 00 00
00 b0 10 00 c3 2a c4 59

-- PCI devices --
00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
00: 06 11 23 31 06 00 30 22 00 00 00 06 00 08 00 00
10: 08 00 00 d0 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 06 11 01 aa
30: 00 00 00 00 a0 00 00 00 00 00 00 00 00 00 00 00

01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo
CLE266] integrated CastleRock graphics (rev 03)
00: 06 11 22 31 07 00 10 02 03 00 00 03 00 20 00 00
10: 08 00 00 d8 00 00 00 dc 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 06 11 22 31
30: 00 00 00 00 60 00 00 00 00 00 00 00 0b 01 02 00

thank you!

/edward

Andreas Robinson wrote:

>Yidan(Edward) Zhou wrote:
>
>  
>
>>However, when i run 'text' and 'image' in the
>>tutorial package, these two programs can not show the png picture and
>>the decker font. the picture and the characters are replaced by blanks
>>with random dots on it.
>>    
>>
>
>Like Andi says, acceleration doesn't seem to work for you. Please try
>df_andi and some other examples.
>
>If they don't work either, the hardware could be misconfigured for your
>particular setup, even though it looks like you have exactly the same
>CLE266
>chip as everyone else (VT3122, rev 3). The answer is then likely to be
>in
>some obscure FIFO/arbiter/PCI register... :-/
>
>I've attached a small script which prints some hardware information.
>
>Install cle266vgaio and run a directfb program. Make sure it produces
>the
>same blank images with random dots you got before.
>Then run the script, and post the output to this list. I'll compare your
>results with my own. Maybe something is different.
>
>A few questions:
>
>* What type of RAM do you have installed? What speed is it? (266MHz?
>200MHz?) Is it a brand-name or no-name type?
>* What BIOS revision do you have? 1.0F?
>
>Regards,
>Andreas
>
>PS.
>I sent you a couple of suggestions regarding the video overlay before.
>Did
>they help? If so, what was the solution?
>DS
>
>  
>




-- 
Info: To unsubscribe send a mail to ecartis@directfb.org with 
"unsubscribe directfb-users" as subject.



Home | Main Index | Thread Index


directfb.org / Development / Old Archives