DirectFB - Home of the pragmatist Roadmap


[directfb-users] DirectFB-extra (df_xine) "xine_open_video_driver Faile
Mailing List archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[directfb-users] DirectFB-extra (df_xine) "xine_open_video_driver Failed!"



Hi list,

I',m trying to make the df_xine sample from DirectFB-extra (current CVS) work. I compiled it against current CVS DirectFB, DFB++ and xine-lib-1-rc4a.

Don't remember the exact contents of /etc/directfbrc, as I'm at work right now (and forgot to paste that one too in the file where I took the output below with me) but it's setup to work on my Matrox G400 DH TV-out, and freevo-1.5rc2 together with a few weeks old CVS mplayer work just fine with DirecFB on my TV (no monitor attached).

When I run df_xine in a ssh session on that machine, The TV flickers for a second or 2 and then the signal disappears again (my TV shows a blue chroma when no signal is detected), and this is the output:


htpc root # df_xine /1.mpg
(*) DirectFB/Config: Parsing config file '/etc/directfbrc'.

---------------------- DirectFB v0.9.21 ---------------------
(c) 2000-2002 convergence integrated media GmbH
(c) 2002-2004 convergence GmbH
-----------------------------------------------------------

(*) DirectFB/Core: Multi Application Core. (with MMX support) (2004-06-02 23:09)
(!) Direct/Modules: Unable to dlopen `/usr/local/lib/directfb-0.9.21/systems/libdirectfb_sdl.so'!
--> /usr/local/lib/directfb-0.9.21/systems/libdirectfb_sdl.so: undefined symbol: dfb_modules_register
(*) Direct/Memcpy: Using MMXEXT optimized memcpy()
(*) Direct/Thread: Running 'Fusion Dispatch' (MESSAGING, 19019)...
(!) Direct/Modules: Unable to dlopen `/usr/local/lib/directfb-0.9.21/inputdrivers/libdirectfb_sdlinput.so'!
--> /usr/local/lib/directfb-0.9.21/inputdrivers/libdirectfb_sdlinput.so: undefined symbol: dfb_modules_register
(*) Direct/Modules: suppress module 'joystick'
(*) Direct/Modules: suppress module 'lirc'
(*) Direct/Modules: suppress module 'ps2mouse'
(*) Direct/Thread: Running 'Keyboard Input' (INPUT, 19031)...
(*) DirectFB/Input: Keyboard 0.9 (convergence integrated media GmbH)
(*) DirectFB/Genefx: MMX detected and enabled
(*) DirectFB/Graphics: Matrox G400 0.7 (convergence integrated media GmbH)
(*) DirectFB/WM: Default 0.1 (Convergence GmbH)
(!!!) *** WARNING [no video mode set yet] *** [layers.c:536 in dfb_screen_rectangle()]
(!!!) *** WARNING [no video mode set yet] *** [layers.c:536 in dfb_screen_rectangle()]
df_xine: here we go!
df_xine: scanning layers for a suitable one
df_xine: trying layer 2
df_xine: -> has a surface
df_xine: -> not enough!
df_xine: trying layer 1
df_xine: -> has a surface
df_xine: -> supports screen location
df_xine: -> trying to access... (!!!) *** WARNING [no video mode set yet] *** [layers.c:536 in dfb_screen_rectangle()]
(!!!) *** WARNING [no video mode set yet] *** [layers.c:536 in dfb_screen_rectangle()]
ok
df_xine: -> checking if UYVY is supported...yes
df_xine: -> checking if YUY2 is supported...yes
df_xine: -> checking if I420 is supported...yes
df_xine: -> checking if YV12 is supported...yes
df_xine: using layer 1 [Matrox Backend Scaler]
df_xine.c <1184>: [vo = xine_open_video_driver(xine, "DFB", XINE_VISUAL_TYPE_DFB, (void*) &visual)] Failed!


I tried this with differnt video files, so it seems that's not the issue here, but this very last line where it says the video output driver couldn't be opened.
fbxine from xine-ui-0.99.1 of course, doesn't work at all, it segfaults after managing to say "Failed to set /dev/tty to graphics mode: Invalid argument", but I think the built-in DFB-support in xine is unmaintained for a long time, and questions about this seem to remain unaswered on their mailing lists.
Am I doing something wrong? As I said, I don't have the /etc/directfbrc with me, but I'll provide it when I get home and someone needs that info, just please tell me

Greets,
Lucian





Home | Main Index | Thread Index


directfb.org / Development / Old Archives